Browse Source

Disable git-archive

Since configure uses git-version-gen which in turn depends
on "git describe" or  a .tarball-version file, raw archives
generated by "git archive" cannot be built.

* .gitattributes: New file.
* README-github_gitlab-autogenerated-archives.txt: Likewise.
Dmitry V. Levin 1 year ago
parent
commit
9eeab98448
2 changed files with 13 additions and 0 deletions
  1. 2
    0
      .gitattributes
  2. 11
    0
      README-github_gitlab-autogenerated-archives.txt

+ 2
- 0
.gitattributes View File

@@ -0,0 +1,2 @@
1
+/* export-ignore
2
+/README-github_gitlab-autogenerated-archives.txt -export-ignore

+ 11
- 0
README-github_gitlab-autogenerated-archives.txt View File

@@ -0,0 +1,11 @@
1
+github/gitlab autogenerated archives are not supported
2
+======================================================
3
+
4
+This information applies to bundles automatically generated
5
+by github and gitlab.
6
+
7
+strace's program version is maintained using git-version-gen script, therefore,
8
+building strace depends on "git describe" (a full git clone is needed for this)
9
+or, alternatively, a .tarball-version file.  Neither github nor gitlab can
10
+provide the latter, they also do not allow to inject a .tarball-version file
11
+during export archiving.

Loading…
Cancel
Save