Mirror of metasploit
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Brendan Coles 163c66b5ba Update tested versions 4 months ago
.github update PR template to ask for unique branch 7 months ago
app Move shared example from pro into framework 3 years ago
config just print the error, but don't give specific advice 5 months ago
data reduced file size 4 months ago
db automatic module_metadata_base.json update 4 months ago
docker remove debug output 10 months ago
documentation Update tested versions 4 months ago
external Merge remote-tracking branch 'upstream/master' into land-10812- 6 months ago
lib Bump version of framework to 5.0.19 4 months ago
modules Update tested versions 4 months ago
plugins Land #11603, Fail nicely when load aggregator. 5 months ago
script kill cucumber in framework 2 years ago
scripts Fixed Typos 1 year ago
spec Update spec with new intended cmd_creds behavior 4 months ago
test fix loadpath test/modules 9 months ago
tools fix Failure scoping (needed for libraries) 4 months ago
.dockerignore change docker root exec 10 months ago
.gitignore Land #9220, Module cache improvements 1 year ago
.gitmodules Add RDI submodule, port Kitrap0d 5 years ago
.mailmap revisionism 7 months ago
.rspec Add modern --require to .rspec 4 years ago
.rubocop.yml remove Ruby 2.2 constraint 5 months ago
.ruby-gemset Remove gitignore, change to metasploit-framework 6 years ago
.ruby-version ruby 2.6.2 5 months ago
.simplecov Remove fastlib 4 years ago
.travis.yml update ruby 2.5.5 too 5 months ago
.yardopts remove HACKING from yardopts 1 year ago
CODE_OF_CONDUCT.md Change individual contacts 8 months ago
CONTRIBUTING.md Update CONTRIBUTING.md advice on topic branches 4 months ago
COPYING Update COPYING 1 year ago
CURRENT.md add CURRENT.md to track major changes and how to migrate with them 1 year ago
Dockerfile ruby 2.6.2 5 months ago
Gemfile Bump to released metasm 1.0.4 4 months ago
Gemfile.local.example update Gemfile.local example, use Gemfile.local if it exists when bundling 2 years ago
Gemfile.lock Bump version of framework to 5.0.19 4 months ago
LICENSE add jtr license 6 months ago
LICENSE_GEMS Bump version of framework to 5.0.19 4 months ago
README.md add docker pull badge to readme 1 year ago
Rakefile trying rspec-retry 2 years ago
Vagrantfile neither Dockerfile nor Vagrant should actually install bundler these days 5 months ago
docker-compose.override.yml change docker root exec 10 months ago
docker-compose.yml change docker root exec 10 months ago
metasploit-framework.gemspec Bump metasploit_payloads-mettle to 0.5.12 4 months ago
msf-json-rpc.ru Move under Msf::WebServices namespace 9 months ago
msf-ws.ru Add Metasploit data web service rackup file 7 months ago
msfconsole Improved CTRL-C edge case, Invalid Options edge case, help output, version output 1 year ago
msfd Removing unnecessary spaces 1 year ago
msfdb Don't delete ssl key and cert if a user asked not to 5 months ago
msfrpc Removing unnecessary spaces 1 year ago
msfrpcd Add background process ID output 7 months ago
msfupdate remove "require 'os'", not needed or available 1 year ago
msfvenom Add cmd dispatch options -S and -P, msfvenom --sec-name 6 months ago

README.md

Metasploit Build Status Code Climate Docker Pulls

The Metasploit Framework is released under a BSD-style license. See COPYING for more details.

The latest version of this software is available from: https://metasploit.com

Bug tracking and development information can be found at: https://github.com/rapid7/metasploit-framework

New bugs and feature requests should be directed to: https://r-7.co/MSF-BUGv1

API documentation for writing modules can be found at: https://rapid7.github.io/metasploit-framework/api

Questions and suggestions can be sent to: Freenode IRC channel or e-mail the metasploit-hackers mailing list

Installing

Generally, you should use the free installer, which contains all of the dependencies and will get you up and running with a few clicks. See the Dev Environment Setup if you’d like to deal with dependencies on your own.

Using Metasploit

Metasploit can do all sorts of things. The first thing you’ll want to do is start msfconsole, but after that, you’ll probably be best served by reading Metasploit Unleashed, the great community resources, or the wiki.

Contributing

See the Dev Environment Setup guide on GitHub, which will walk you through the whole process from installing all the dependencies, to cloning the repository, and finally to submitting a pull request. For slightly more information, see Contributing.