Mirror of metasploit
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

LICENSE_GEMS 3.5KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. This file is auto-generated by tools/dev/update_gem_licenses.sh
  2. Ascii85, 1.0.3, MIT
  3. actionpack, 4.2.11.1, MIT
  4. actionview, 4.2.11.1, MIT
  5. activemodel, 4.2.11.1, MIT
  6. activerecord, 4.2.11.1, MIT
  7. activesupport, 4.2.11.1, MIT
  8. addressable, 2.6.0, "Apache 2.0"
  9. afm, 0.2.2, MIT
  10. arel, 6.0.4, MIT
  11. arel-helpers, 2.8.0, MIT
  12. backports, 3.15.0, MIT
  13. bcrypt, 3.1.12, MIT
  14. bcrypt_pbkdf, 1.0.1, MIT
  15. bindata, 2.4.4, ruby
  16. bit-struct, 0.16, ruby
  17. builder, 3.2.3, MIT
  18. bundler, 1.17.3, MIT
  19. coderay, 1.1.2, MIT
  20. concurrent-ruby, 1.0.5, MIT
  21. cookiejar, 0.3.3, unknown
  22. crass, 1.0.4, MIT
  23. daemons, 1.3.1, MIT
  24. diff-lcs, 1.3, "MIT, Artistic-2.0, GPL-2.0+"
  25. dnsruby, 1.61.2, "Apache 2.0"
  26. docile, 1.3.1, MIT
  27. ed25519, 1.2.4, MIT
  28. em-http-request, 1.1.5, MIT
  29. em-socksify, 0.3.2, MIT
  30. erubis, 2.7.0, MIT
  31. eventmachine, 1.2.7, "ruby, GPL-2.0"
  32. factory_bot, 5.0.2, MIT
  33. factory_bot_rails, 5.0.2, MIT
  34. faker, 1.9.3, MIT
  35. faraday, 0.15.4, MIT
  36. filesize, 0.2.0, MIT
  37. fivemat, 1.3.7, MIT
  38. hashery, 2.1.2, "Simplified BSD"
  39. http_parser.rb, 0.6.0, MIT
  40. i18n, 0.9.5, MIT
  41. jsobfu, 0.4.2, "New BSD"
  42. json, 2.2.0, ruby
  43. loofah, 2.2.3, MIT
  44. metasm, 1.0.4, LGPL-2.1
  45. metasploit-concern, 2.0.5, "New BSD"
  46. metasploit-credential, 3.0.3, "New BSD"
  47. metasploit-framework, 5.0.25, "New BSD"
  48. metasploit-model, 2.0.4, "New BSD"
  49. metasploit-payloads, 1.3.66, "3-clause (or ""modified"") BSD"
  50. metasploit_data_models, 3.0.10, "New BSD"
  51. metasploit_payloads-mettle, 0.5.13, "3-clause (or ""modified"") BSD"
  52. method_source, 0.9.2, MIT
  53. mini_portile2, 2.4.0, MIT
  54. minitest, 5.11.3, MIT
  55. mqtt, 0.5.0, MIT
  56. msgpack, 1.2.10, "Apache 2.0"
  57. multipart-post, 2.1.1, MIT
  58. nessus_rest, 0.1.6, MIT
  59. net-ssh, 5.2.0, MIT
  60. network_interface, 0.0.2, MIT
  61. nexpose, 7.2.1, "New BSD"
  62. nokogiri, 1.10.3, MIT
  63. octokit, 4.14.0, MIT
  64. openssl-ccm, 1.2.2, MIT
  65. openvas-omp, 0.0.4, MIT
  66. packetfu, 1.1.13, BSD
  67. patch_finder, 1.0.2, "New BSD"
  68. pcaprub, 0.13.0, LGPL-2.1
  69. pdf-reader, 2.2.0, MIT
  70. pg, 0.21.0, "New BSD"
  71. pg_array_parser, 0.0.9, unknown
  72. postgres_ext, 3.0.1, MIT
  73. pry, 0.12.2, MIT
  74. public_suffix, 3.0.3, MIT
  75. rack, 1.6.11, MIT
  76. rack-protection, 1.5.5, MIT
  77. rack-test, 0.6.3, MIT
  78. rails-deprecated_sanitizer, 1.0.3, MIT
  79. rails-dom-testing, 1.0.9, MIT
  80. rails-html-sanitizer, 1.0.4, MIT
  81. railties, 4.2.11.1, MIT
  82. rake, 12.3.2, MIT
  83. rb-readline, 0.5.5, BSD
  84. recog, 2.3.2, unknown
  85. redcarpet, 3.4.0, MIT
  86. rex-arch, 0.1.13, "New BSD"
  87. rex-bin_tools, 0.1.6, "New BSD"
  88. rex-core, 0.1.13, "New BSD"
  89. rex-encoder, 0.1.4, "New BSD"
  90. rex-exploitation, 0.1.20, "New BSD"
  91. rex-java, 0.1.5, "New BSD"
  92. rex-mime, 0.1.5, "New BSD"
  93. rex-nop, 0.1.1, "New BSD"
  94. rex-ole, 0.1.6, "New BSD"
  95. rex-powershell, 0.1.82, "New BSD"
  96. rex-random_identifier, 0.1.4, "New BSD"
  97. rex-registry, 0.1.3, "New BSD"
  98. rex-rop_builder, 0.1.3, "New BSD"
  99. rex-socket, 0.1.17, "New BSD"
  100. rex-sslscan, 0.1.5, "New BSD"
  101. rex-struct2, 0.1.2, "New BSD"
  102. rex-text, 0.2.21, "New BSD"
  103. rex-zip, 0.1.3, "New BSD"
  104. rkelly-remix, 0.0.7, MIT
  105. rspec, 3.8.0, MIT
  106. rspec-core, 3.8.0, MIT
  107. rspec-expectations, 3.8.3, MIT
  108. rspec-mocks, 3.8.0, MIT
  109. rspec-rails, 3.8.2, MIT
  110. rspec-rerun, 1.1.0, MIT
  111. rspec-support, 3.8.0, MIT
  112. ruby-macho, 2.2.0, MIT
  113. ruby-rc4, 0.1.5, MIT
  114. ruby_smb, 1.0.5, "New BSD"
  115. rubyntlm, 0.6.2, MIT
  116. rubyzip, 1.2.3, "Simplified BSD"
  117. sawyer, 0.8.2, MIT
  118. simplecov, 0.16.1, MIT
  119. simplecov-html, 0.10.2, MIT
  120. sinatra, 1.4.8, MIT
  121. sqlite3, 1.3.13, "New BSD"
  122. sshkey, 2.0.0, MIT
  123. swagger-blocks, 2.0.2, MIT
  124. thin, 1.7.2, "GPLv2+, Ruby 1.8"
  125. thor, 0.20.3, MIT
  126. thread_safe, 0.3.6, "Apache 2.0"
  127. tilt, 2.0.9, MIT
  128. timecop, 0.9.1, MIT
  129. ttfunk, 1.5.1, "Nonstandard, GPL-2.0, GPL-3.0"
  130. tzinfo, 1.2.5, MIT
  131. tzinfo-data, 1.2019.1, MIT
  132. warden, 1.2.7, MIT
  133. windows_error, 0.1.2, BSD
  134. xdr, 2.0.0, "Apache 2.0"
  135. xmlrpc, 0.3.0, ruby
  136. yard, 0.9.19, MIT