Browse Source

bump gems, lock ruby_smb for now

Brent Cook 1 year ago
parent
commit
d737f77b84
2 changed files with 14 additions and 14 deletions
  1. 13
    13
      Gemfile.lock
  2. 1
    1
      metasploit-framework.gemspec

+ 13
- 13
Gemfile.lock View File

@@ -59,7 +59,7 @@ PATH
59 59
       rex-text
60 60
       rex-zip
61 61
       ruby-macho
62
-      ruby_smb
62
+      ruby_smb (= 0.0.18)
63 63
       rubyntlm
64 64
       rubyzip
65 65
       sqlite3
@@ -125,11 +125,11 @@ GEM
125 125
       railties (>= 3.0.0)
126 126
     faker (1.8.7)
127 127
       i18n (>= 0.7)
128
-    faraday (0.13.1)
128
+    faraday (0.14.0)
129 129
       multipart-post (>= 1.2, < 3)
130 130
     filesize (0.1.1)
131 131
     fivemat (1.3.5)
132
-    google-protobuf (3.5.1)
132
+    google-protobuf (3.5.1.2)
133 133
     googleapis-common-protos-types (1.0.1)
134 134
       google-protobuf (~> 3.0)
135 135
     googleauth (0.6.2)
@@ -140,12 +140,12 @@ GEM
140 140
       multi_json (~> 1.11)
141 141
       os (~> 0.9)
142 142
       signet (~> 0.7)
143
-    grpc (1.8.3)
143
+    grpc (1.9.1)
144 144
       google-protobuf (~> 3.1)
145 145
       googleapis-common-protos-types (~> 1.0.0)
146 146
       googleauth (>= 0.5.1, < 0.7)
147 147
     hashery (2.1.2)
148
-    i18n (0.9.1)
148
+    i18n (0.9.5)
149 149
       concurrent-ruby (~> 1.0)
150 150
     jsobfu (0.4.2)
151 151
       rkelly-remix
@@ -155,7 +155,7 @@ GEM
155 155
     logging (2.2.2)
156 156
       little-plugger (~> 1.1)
157 157
       multi_json (~> 1.10)
158
-    loofah (2.1.1)
158
+    loofah (2.2.0)
159 159
       crass (~> 1.0.2)
160 160
       nokogiri (>= 1.5.9)
161 161
     memoist (0.16.0)
@@ -167,7 +167,7 @@ GEM
167 167
       activemodel (~> 4.2.6)
168 168
       activesupport (~> 4.2.6)
169 169
       railties (~> 4.2.6)
170
-    metasploit-credential (2.0.12)
170
+    metasploit-credential (2.0.13)
171 171
       metasploit-concern
172 172
       metasploit-model
173 173
       metasploit_data_models
@@ -194,7 +194,7 @@ GEM
194 194
     metasploit_payloads-mettle (0.3.7)
195 195
     method_source (0.9.0)
196 196
     mini_portile2 (2.3.0)
197
-    minitest (5.11.1)
197
+    minitest (5.11.3)
198 198
     mqtt (0.5.0)
199 199
     msgpack (1.2.2)
200 200
     multi_json (1.13.1)
@@ -203,7 +203,7 @@ GEM
203 203
     net-ssh (4.2.0)
204 204
     network_interface (0.0.2)
205 205
     nexpose (7.2.0)
206
-    nokogiri (1.8.1)
206
+    nokogiri (1.8.2)
207 207
       mini_portile2 (~> 2.3.0)
208 208
     octokit (4.8.0)
209 209
       sawyer (~> 0.8.0, >= 0.5.3)
@@ -214,7 +214,7 @@ GEM
214 214
       pcaprub
215 215
     patch_finder (1.0.2)
216 216
     pcaprub (0.12.4)
217
-    pdf-reader (2.0.0)
217
+    pdf-reader (2.1.0)
218 218
       Ascii85 (~> 1.0.0)
219 219
       afm (~> 0.2.1)
220 220
       hashery (~> 2.0)
@@ -229,7 +229,7 @@ GEM
229 229
     pry (0.11.3)
230 230
       coderay (~> 1.1.0)
231 231
       method_source (~> 0.9.0)
232
-    public_suffix (3.0.1)
232
+    public_suffix (3.0.2)
233 233
     rack (1.6.8)
234 234
     rack-test (0.6.3)
235 235
       rack (>= 1.0)
@@ -320,7 +320,7 @@ GEM
320 320
       rspec-support (~> 3.7.0)
321 321
     rspec-rerun (1.1.0)
322 322
       rspec (~> 3.0)
323
-    rspec-support (3.7.0)
323
+    rspec-support (3.7.1)
324 324
     ruby-macho (1.1.0)
325 325
     ruby-rc4 (0.1.5)
326 326
     ruby_smb (0.0.18)
@@ -348,7 +348,7 @@ GEM
348 348
     thread_safe (0.3.6)
349 349
     timecop (0.9.1)
350 350
     ttfunk (1.5.1)
351
-    tzinfo (1.2.4)
351
+    tzinfo (1.2.5)
352 352
       thread_safe (~> 0.1)
353 353
     tzinfo-data (1.2018.3)
354 354
       tzinfo (>= 1.0.0)

+ 1
- 1
metasploit-framework.gemspec View File

@@ -127,7 +127,7 @@ Gem::Specification.new do |spec|
127 127
   spec.add_runtime_dependency 'mqtt'
128 128
   spec.add_runtime_dependency 'net-ssh'
129 129
   spec.add_runtime_dependency 'bcrypt_pbkdf'
130
-  spec.add_runtime_dependency 'ruby_smb'
130
+  spec.add_runtime_dependency 'ruby_smb', '0.0.18'
131 131
 
132 132
   #
133 133
   # REX Libraries

Loading…
Cancel
Save