Browse Source

Bump version of framework to 5.0.20

Metasploit 3 months ago
parent
commit
b5f164335e
No account linked to committer's email address
3 changed files with 11 additions and 11 deletions
  1. 5
    5
      Gemfile.lock
  2. 5
    5
      LICENSE_GEMS
  3. 1
    1
      lib/metasploit/framework/version.rb

+ 5
- 5
Gemfile.lock View File

@@ -1,7 +1,7 @@
1 1
 PATH
2 2
   remote: .
3 3
   specs:
4
-    metasploit-framework (5.0.19)
4
+    metasploit-framework (5.0.20)
5 5
       actionpack (~> 4.2.6)
6 6
       activerecord (~> 4.2.6)
7 7
       activesupport (~> 4.2.6)
@@ -193,13 +193,13 @@ GEM
193 193
     mini_portile2 (2.4.0)
194 194
     minitest (5.11.3)
195 195
     mqtt (0.5.0)
196
-    msgpack (1.2.9)
196
+    msgpack (1.2.10)
197 197
     multipart-post (2.0.0)
198 198
     nessus_rest (0.1.6)
199 199
     net-ssh (5.2.0)
200 200
     network_interface (0.0.2)
201 201
     nexpose (7.2.1)
202
-    nokogiri (1.10.2)
202
+    nokogiri (1.10.3)
203 203
       mini_portile2 (~> 2.4.0)
204 204
     octokit (4.14.0)
205 205
       sawyer (~> 0.8.0, >= 0.5.3)
@@ -274,7 +274,7 @@ GEM
274 274
       rex-arch
275 275
     rex-ole (0.1.6)
276 276
       rex-text
277
-    rex-powershell (0.1.80)
277
+    rex-powershell (0.1.82)
278 278
       rex-random_identifier
279 279
       rex-text
280 280
     rex-random_identifier (0.1.4)
@@ -301,7 +301,7 @@ GEM
301 301
       rspec-mocks (~> 3.8.0)
302 302
     rspec-core (3.8.0)
303 303
       rspec-support (~> 3.8.0)
304
-    rspec-expectations (3.8.2)
304
+    rspec-expectations (3.8.3)
305 305
       diff-lcs (>= 1.2.0, < 2.0)
306 306
       rspec-support (~> 3.8.0)
307 307
     rspec-mocks (3.8.0)

+ 5
- 5
LICENSE_GEMS View File

@@ -44,7 +44,7 @@ loofah, 2.2.3, MIT
44 44
 metasm, 1.0.4, LGPL-2.1
45 45
 metasploit-concern, 2.0.5, "New BSD"
46 46
 metasploit-credential, 3.0.3, "New BSD"
47
-metasploit-framework, 5.0.19, "New BSD"
47
+metasploit-framework, 5.0.20, "New BSD"
48 48
 metasploit-model, 2.0.4, "New BSD"
49 49
 metasploit-payloads, 1.3.66, "3-clause (or ""modified"") BSD"
50 50
 metasploit_data_models, 3.0.8, "New BSD"
@@ -53,13 +53,13 @@ method_source, 0.9.2, MIT
53 53
 mini_portile2, 2.4.0, MIT
54 54
 minitest, 5.11.3, MIT
55 55
 mqtt, 0.5.0, MIT
56
-msgpack, 1.2.9, "Apache 2.0"
56
+msgpack, 1.2.10, "Apache 2.0"
57 57
 multipart-post, 2.0.0, MIT
58 58
 nessus_rest, 0.1.6, MIT
59 59
 net-ssh, 5.2.0, MIT
60 60
 network_interface, 0.0.2, MIT
61 61
 nexpose, 7.2.1, "New BSD"
62
-nokogiri, 1.10.2, MIT
62
+nokogiri, 1.10.3, MIT
63 63
 octokit, 4.14.0, MIT
64 64
 openssl-ccm, 1.2.2, MIT
65 65
 openvas-omp, 0.0.4, MIT
@@ -92,7 +92,7 @@ rex-java, 0.1.5, "New BSD"
92 92
 rex-mime, 0.1.5, "New BSD"
93 93
 rex-nop, 0.1.1, "New BSD"
94 94
 rex-ole, 0.1.6, "New BSD"
95
-rex-powershell, 0.1.80, "New BSD"
95
+rex-powershell, 0.1.82, "New BSD"
96 96
 rex-random_identifier, 0.1.4, "New BSD"
97 97
 rex-registry, 0.1.3, "New BSD"
98 98
 rex-rop_builder, 0.1.3, "New BSD"
@@ -104,7 +104,7 @@ rex-zip, 0.1.3, "New BSD"
104 104
 rkelly-remix, 0.0.7, MIT
105 105
 rspec, 3.8.0, MIT
106 106
 rspec-core, 3.8.0, MIT
107
-rspec-expectations, 3.8.2, MIT
107
+rspec-expectations, 3.8.3, MIT
108 108
 rspec-mocks, 3.8.0, MIT
109 109
 rspec-rails, 3.8.2, MIT
110 110
 rspec-rerun, 1.1.0, MIT

+ 1
- 1
lib/metasploit/framework/version.rb View File

@@ -30,7 +30,7 @@ module Metasploit
30 30
         end
31 31
       end
32 32
 
33
-      VERSION = "5.0.19"
33
+      VERSION = "5.0.20"
34 34
       MAJOR, MINOR, PATCH = VERSION.split('.').map { |x| x.to_i }
35 35
       PRERELEASE = 'dev'
36 36
       HASH = get_hash

Loading…
Cancel
Save