Browse Source

Remove dead version check in db_manager.rb

The check appears to have been orphaned in the db_manager refactor, but
I can't track down the exact commit.
Adam Cammack 3 years ago
parent
commit
32fe9ae55d
No account linked to committer's email address
2 changed files with 0 additions and 11 deletions
  1. 0
    10
      lib/msf/core/db_manager.rb
  2. 0
    1
      spec/lib/msf/db_manager_spec.rb

+ 0
- 10
lib/msf/core/db_manager.rb View File

@@ -163,14 +163,4 @@ class Msf::DBManager
163 163
 
164 164
     true
165 165
   end
166
-
167
-  # Mainly, it's Ruby 1.9.1 that cause a lot of problems now, along with Ruby 1.8.6.
168
-  # Ruby 1.8.7 actually seems okay, but why tempt fate? Let's say 1.9.3 and beyond.
169
-  def warn_about_rubies
170
-    if ::RUBY_VERSION =~ /^1\.9\.[012]($|[^\d])/
171
-      $stderr.puts "**************************************************************************************"
172
-      $stderr.puts "Metasploit requires at least Ruby 1.9.3. For an easy upgrade path, see https://rvm.io/"
173
-      $stderr.puts "**************************************************************************************"
174
-    end
175
-  end
176 166
 end

+ 0
- 1
spec/lib/msf/db_manager_spec.rb View File

@@ -52,5 +52,4 @@ RSpec.describe Msf::DBManager do
52 52
   it { is_expected.to respond_to :error }
53 53
   it { is_expected.to respond_to :initialize_database_support }
54 54
   it { is_expected.to respond_to :service_name_map }
55
-  it { is_expected.to respond_to :warn_about_rubies }
56 55
 end

Loading…
Cancel
Save