Hugo Dark Theme Site Generator https://after-dark.habd.as
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

package.json 2.0KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. {
  2. "name": "after-dark",
  3. "version": "6.7.6",
  4. "description": "A deceptively simple dark theme for Hugo.",
  5. "author": "Josh Habdas <jhabdas@protonmail.com>",
  6. "keywords": [
  7. "docker",
  8. "hugo",
  9. "css",
  10. "html",
  11. "vuejs",
  12. "bash"
  13. ],
  14. "repository": {
  15. "type": "git",
  16. "url": "https://git.habd.as/comfusion/after-dark.git"
  17. },
  18. "standard-version": {
  19. "scripts": {
  20. "posttag": "git tag --sign $(git describe --tags $(git rev-list --tags --max-count=1)) $(git describe --tags $(git rev-list --tags --max-count=1))^{} -f -m \"$(git log -1 --pretty=%B)\" -m \"-----BEGIN DIST INTEGRITY-----\" -m \"$(npm pack --dry-run --json . | grep integrity | cut -d ',' -f1 | cut -d ':' -f2 | tr -d '\" ')\" -m \"-----END DIST INTEGRITY-----\""
  21. }
  22. },
  23. "scripts": {
  24. "update:lazysizes": "npm up lazysizes && cp -i node_modules/lazysizes/lazysizes.min.js static/js",
  25. "update:lodash:custom": "./node_modules/.bin/lodash include=debounce -p -o static/js/lodash.custom.min.js",
  26. "update:smoothscroll": "npm up smoothscroll && cp -i node_modules/smoothscroll-polyfill/dist/smoothscroll.js static/js",
  27. "update:fuse": "npm up fuse.js && cp -i node_modules/fuse.js/dist/fuse.min.js static/js",
  28. "update:vue": "npm up vue && cp -i node_modules/vue/dist/vue.min.js static/js",
  29. "update:mark": "npm up mark.js && cp -i node_modules/mark.js/dist/mark.min.js static/js",
  30. "update:hackcss": "npm up hackcss && cp -ir node_modules/hack/dist/ assets/css/vendor/hack/",
  31. "test": "while true; do head -n 100 /dev/urandom; sleep 0.1; done | hexdump -C | grep 'ca fe'",
  32. "integrity": "npm pack --dry-run --json . | grep integrity | cut -d ',' -f1 | cut -d ':' -f2 | tr -d '\" '",
  33. "release": "standard-version"
  34. },
  35. "devDependencies": {
  36. "atom-one-chroma": "^2.0.0",
  37. "fuse.js": "^3.2.1",
  38. "hack": "^0.8.1",
  39. "lazysizes": "^4.0.4",
  40. "mark.js": "^8.11.1",
  41. "smoothscroll-polyfill": "^0.4.3",
  42. "vue": "^2.5.16",
  43. "lodash-cli": "^4.17.5",
  44. "standard-version": "^4.4.0"
  45. },
  46. "license": "WTFPL"
  47. }