#138 Photo not working

Closed
opened 7 months ago by Ghost · 2 comments
Ghost commented 7 months ago

https://after-dark.habd.as/id/feature/lazy-loading/

Unsplash CSP: “img-src “img-src ‘self’ data:”

https://after-dark.habd.as/id/feature/lazy-loading/ Unsplash CSP: "img-src "img-src 'self' data:"
jhabdas commented 7 months ago
Owner

Thanks for catching that. Will look into it soon.

Thanks for catching that. Will look into it soon.
jhabdas added the
chore
label 7 months ago
jhabdas commented 7 months ago
Owner

All fixed. Since After Docs uses Advanced CSP images from external sites were disabled in order to secure users against potential 3rd party cookies (in case their browser doesn’t disable them already). I checked and Unsplash isn’t serving any cookies so I whitelisted them in the commit which closed this issue. Cheers and thanks for the report.

All fixed. Since After Docs uses [Advanced CSP](https://after-dark.habd.as/feature/content-security-policy/#advanced-configuration) images from external sites were disabled in order to secure users against potential 3rd party cookies (in case their browser doesn't disable them already). I checked and Unsplash isn't serving any cookies so I whitelisted them in the commit which closed this issue. Cheers and thanks for the report.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.